Certificate Rotation has been completed successfully - We are continuing to monitor the success of this rotation
Posted Aug 06, 2025 - 10:33 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 06, 2025 - 10:00 UTC
Scheduled
We will be performing scheduled maintenance to rotate our Apple Pay Payment Processing certificates in our EU production environment.
This is a routine update to ensure continued operation and uninterrupted service of Apple Pay via BR-DGE.
No downtime or service interruption is expected, and your customers can continue to use Apple Pay during this time.
This maintenance will only be carried out in the EU Production environment and is only relevant to merchants who integrate using the BR-DGE Hosted Payment Page, or WebSDK.
Posted Aug 05, 2025 - 10:00 UTC
This scheduled maintenance affected: Payment Methods (Apple Pay).